use strict;
my $str = 'x-x="11111" y-y="John-Doe 23" db {rty=\'Y453\'} code {codeDate=\'2000-03-01T00:00:00\'}';
my $regex = qr/([\w-]+)=((['"]).*?\3)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}