re = /^(\d+)[^\d]+([+-]?[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{2})?)$/m
str = '2 book at 12.99
4 potato chips at 3.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end