Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(= new ReportViewModel\d+)\((id)\)
/
mg
Input 1
1
New
= new ReportViewModel83(id) = new ReportViewModel8(id) = new ReportViewModel111(id) = new ReportViewModel20() = new ReportViewModel1(null)
Substitution
$1($2,_ModelParam.Id)