// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(?:.*\n){0,10}).*?Error.*(?:(?:\n.*){0,10})").unwrap();
let string = "1
2
3
4
5
6
7
8
9
10
TypeError: Parameter 'url' must be a string, not undefined at Url.parse (url.js:107:11) at urlParse (url.js:101:5) at Object.urlResolve [as resolve] (url.js:404:10) at parseMarkdown (/opt/controllers/api/userguide.js:53:19) at /opt/controllers/api/userguide.js:33:17 at Object. (/opt/models/api.js:172:4) at /opt/lib/data/api.js:138:5 at IncomingMessage. (/opt/node_modules/httpunch/lib/_wrap_request.js:100:9) at IncomingMessage.g (events.js:180:16) at IncomingMessage.emit (events.js:117:20)
1
2
3
4
5
6
7
8
9
10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}