using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))";
string input = @"16.17.18090901
16.16.19041201
15.33.17040900";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}