package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(1[0-5]|16\.(1[1-5]|16\.(1[0-8]|190[0-3])))`)
var str = `16.17.18090901
16.16.19041201
15.33.17040900`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}