const regex = /(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\(( (?:"[A-Z0-9]{2}"(?:[, ])*)+)\)(?: +)THEN ([A-Z0-9\-]+) ="([A-Z]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\\(( (?:"[A-Z0-9]{2}"(?:[, ])*)+)\\)(?: +)THEN ([A-Z0-9\\-]+) ="([A-Z]+)"', 'gm')
const str = `IF KNVV -> KDGRP IN( "EK", "ES" ) THEN KNA1-SORTL ="KA"
ELSE KNVV -> KDGRP IN( "EL", "E3", "E5", "E7", "E2", "EF" ) THEN KNA1-SORTL ="IN"
ELSE KNVV -> KDGRP IN( "EX", "EU", "EV", "ET", "EW" ) THEN KNA1-SORTL ="CA"
END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}