using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"city[^0-9]*([0-9]+)";
string input = @"city7900/
cityid=7900
city7900-t40094705.nb1/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}