import Foundation
let pattern = #"(?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\\s)?[AP]M)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
Nos dois sistemas.
Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>
escreveu:
> ##- Não escreva abaixo desta linha -##
>
> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*
> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25
>
> *COMENTÁRIO:*
> Bom dia Mayla,
> Apenas sistema Montafarma?
> ------------------------------
>
> *ID Reporte: * #1468
> *Situação: * *ABERTO*
> *Módulo:* Produção
> *Tela:* ordem de pedido
> *Nome: * mayla.capana - MAYLA CAPANA
> *Emissão: * 22/05/2018 12:00:00
> *Fechamento: * -
> *Responsável: * DELTA SI
> *Prioridade: * Urgente
> *Tipo: * Ajuda
>
> *MENSAGEM: *
> Bom dia,
>
> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -
> Ordem de Pedido. (igual a tela que a Iza tem acesso).
>
> Aguardo retorno.
>
> Até,
>
>
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)