using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<right>([^<\/>]*)<\/>?";
string input = @"<right>Phí tex5,000円</>
<right>Phítext5,000円
<right>
Phítext5,000円
</>
<right>
Phítext5,000円</>
<right>
<right>
hello
</>
</>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}