#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)^Name\R(.+)\REmail\R(.+)\RPhone Number\R(.+)\RInquiry or Message\R(?s)(.+)"
Local $sString = "Name" & @CRLF & _
"Troy LastName" & @CRLF & _
"Email" & @CRLF & _
"troytesting3@gmail.com" & @CRLF & _
"Phone Number" & @CRLF & _
"914 361-9012" & @CRLF & _
"Inquiry or Message" & @CRLF & _
"message as a test" & @CRLF & _
"to process"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")