import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^Name\\R(.+)\\REmail\\R(.+)\\RPhone Number\\R(.+)\\RInquiry or Message\\R(?s)(.+)";
        final String string = "Name\n"
	 + "Troy LastName\n"
	 + "Email\n"
	 + "troytesting3@gmail.com\n"
	 + "Phone Number\n"
	 + "914 361-9012\n"
	 + "Inquiry or Message\n"
	 + "message as a test\n"
	 + "to process";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}