#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$"
Local $sString = "CHINA" & @CRLF & _
"CHINA ROM" & @CRLF & _
"CHINA WAREHOUSE" & @CRLF & _
"CHINA-WAREHOUSE" & @CRLF & _
"CHINA-ROM" & @CRLF & _
"dsa china" & @CRLF & _
"CHINALOCAL" & @CRLF & _
"CHINAOO #No"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")