const regex = new RegExp('^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$', 'gmi')
const str = `CHINA
CHINA ROM
CHINA WAREHOUSE
CHINA-WAREHOUSE
CHINA-ROM
dsa china
CHINALOCAL
CHINAOO #No`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}