import Foundation
let pattern = #"(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
help {Jason|Maria|Santa|{Lucia|Raul}'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}'s father
Jason
Maria
Santa
{Lucia|Raul}'s father
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)