#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^ \t]+:)[\s\S]+?(?=^\1|\z)"
Local $sString = "Name: vm346" & @CRLF & _
" cpu 1 (12%) 6150m (76%)" & @CRLF & _
" memory 1130Mi (7%) 1130Mi (7%)" & @CRLF & _
"Name: vm847" & @CRLF & _
" cpu 6 (75%) 30150m (376%)" & @CRLF & _
" memory 12980Mi (87%) 12980Mi (87%)" & @CRLF & _
"Name: vm848" & @CRLF & _
" cpu 3500m (43%) 17150m (214%)" & @CRLF & _
" memory 6216Mi (41%) 6216Mi (41%)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")