# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^ \t]+:)[\s\S]+?(?=^\1|\z)"
test_str = ("Name: vm346\n"
" cpu 1 (12%) 6150m (76%)\n"
" memory 1130Mi (7%) 1130Mi (7%)\n"
"Name: vm847\n"
" cpu 6 (75%) 30150m (376%)\n"
" memory 12980Mi (87%) 12980Mi (87%)\n"
"Name: vm848\n"
" cpu 3500m (43%) 17150m (214%)\n"
" memory 6216Mi (41%) 6216Mi (41%)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.