re = /^(?=(?:[^0-9+]*[0-9+]){9,15}[^0-9+]*$)\+?[0-9.,()\s-]+$/m
str = '+99 999 999
+99 999 999 999 999 999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end