$re = '/,\s*(?![^(]*\))/m';
$str = 'first, second, to_char(my,big,house) as bigly, export(mastermind and others) as aloah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);