const regex = /^(DEFI?)*\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\.[0-9]+)?))\s?(DEFI?)*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(DEFI?)*\\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\\.[0-9]+)?))\\s?(DEFI?)*$', 'g')
const str = `S=20845.2518 DEFI`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}