#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^((\d+[wdhm]\ +?)+|\d+)\ *(.*)$"
Local $sString = "3w 4d 8h 12m Test string" & @CRLF & _
"15m Test string" & @CRLF & _
"123 Test" & @CRLF & _
"50 Test" & @CRLF & _
"123" & @CRLF & _
"1h Test" & @CRLF & _
"2h Test" & @CRLF & _
"3d 4h Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")