import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^C\\w*(?:-\\d+)?(?:-\\d+)?\\W*111\\b";
final String string = "V0EQ21309-128 1 1001600535.99N0023642.63E 478409.56662024.7 107.91520748348\n"
+ "S0EQ21309-128 11 1001600532.60N0023645.31E 478450.26661919.6 0.01520748348\n"
+ "T0EQ21309-128 1 1 1001600452.10N0023713.63E 478880.66660664.0 0.01520748348\n"
+ "T0EQ21309-128 1 2 1001600452.35N0023715.00E 478901.96660671.8 0.01520748348\n"
+ "C0EQ21309-128 111 1001600532.07N0023645.24E 478449.06661903.2 0.01520748348\n"
+ "C0EQ21309-128 113 1001600532.22N0023646.01E 478461.06661907.6 0.01520748348\n"
+ "C012PA105 111 1003660607.77N0080416.09E 458009.87331794.0 365.21171920443\n"
+ "C012PA105 113 1003660607.96N0080415.12E 457997.77331800.2 365.21171920443\n"
+ "C012PA105 122 1004660607.65N0080415.58E 458003.57331790.5 365.31171920472\n"
+ "C012PA105 124 1004660607.84N0080414.62E 457991.47331796.6 365.31171920472";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}