using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*)#\s(?=.*# check=nothing)(.*)$";
string substitution = @"$1$2";
string input = @"parent:
A:
name: foo
value: x.y.z # check=something
# value: ""yay"" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: ""yay"" # check=nothing";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}