const regex = /(^\s*)#\s(?=.*# check=nothing)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\s*)#\\s(?=.*# check=nothing)(.*)$', 'gm')
const str = `parent:
A:
name: foo
value: x.y.z # check=something
# value: "yay" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: "yay" # check=nothing`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);