$re = '/(https?:\/\/|www\.)\S+?\./m';
$str = 'https://test.com
http://test.com
www.test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);