#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(\d+)-(\d+)\s+(.*)"
Local $sString = "3-01 Wait for It.mp4" & @CRLF & _
"3-02 We're Not from Here.mp4" & @CRLF & _
"3-03 Third Wheel.mp4" & @CRLF & _
"3-04 Little Boys.mp4" & @CRLF & _
"3-05 How I Met Everyone Else.mp4" & @CRLF & _
"3-06 I'm Not That Guy.mp4" & @CRLF & _
"3-07 Dowisetrepla.mp4" & @CRLF & _
"3-08 Spoiler Alert.mp4" & @CRLF & _
"3-09 Slapsgiving.mp4" & @CRLF & _
"3-10 The Yips.mp4" & @CRLF & _
"3-11 The Platinum Rule.mp4" & @CRLF & _
"3-12 No Tomorrow.mp4" & @CRLF & _
"3-13 Ten Sessions.mp4" & @CRLF & _
"3-14 The Bracket.mp4" & @CRLF & _
"3-15 The Chain of Screaming.mp4" & @CRLF & _
"3-16 Sandcastles in the Sand.mp4" & @CRLF & _
"3-17 The Goat.mp4" & @CRLF & _
"3-18 Rebound Bro.mp4"
Local $sSubst = "How I Met Your Mother S$1E$2 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)