package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s\d+-[A-Z]+`)
var str = `Есть строки такого содержания:
some text 278094-A, some text 278094-FG, some text 6508-N, some text
Нужно удалить конструкции с цифрами и буквами через дефис, т.е. чтобы стало так:
some text, some text, some text, some text
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}