package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.gg/[a-zA-Z0-9]+`)
var str = `discord.gg/annoyingadvertisingte`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}