re = /https?:\S*/m
str = 'Powerbank for videocamera Canon NB-5L: https://www.esseshop.it/caricabatterie-universale-da-auto-rete-fotocamera-videocamera-p-4452.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end