using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IP (?:\d+|\.|[a-z]()){7}\1[^\n]+";
string input = @"IP bt.ru.https > 192.168.88.10.54276: tcp 3374
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP somedomain.ru.https > 192.168.88.10.54276: tcp 334
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}