import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "IP (?:\\d+|\\.|[a-z]()){7}\\1[^\\n]+";
final String string = "IP bt.ru.https > 192.168.88.10.54276: tcp 3374\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP somedomain.ru.https > 192.168.88.10.54276: tcp 334\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0\n"
+ "IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}