# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^\d+ ?[gm]b | \d+ ?[gm]b(?= |$))"
test_str = ("coolblue 100gb\n"
"connector 500 mb for thing\n"
"5gb for user\n"
"load 800 mb\n"
"1000 add-on\n"
"20 gb ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.