using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",\s*(?=\w+=)";
string input = @"a=1, b=2, c=3
foo=bar, url=http://city.com/Boston, MA US, is_test=false
a=1, b=""2,3"", c=3
foo=""bar, harbor"", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}