# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([2-9]\.)/\n$1/gm;t' <<< "1. abcde. 2. fghijk 3. fghijk"