using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([2-9]\.)";
string substitution = @"\n$1";
string input = @"1. abcde. 2. fghijk 3. fghijk";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}