use strict;
my $str = '{
"_index" : "documents-prod",
"_type" : "_doc",
"_id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620",
"_score" : 0.0,
"_source" : {
"id" : "CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620",
"type" : "CollectiveAgreement",
"title" : "Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)",
"text" : "Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas.",
"path" : "/agreements/19/documents/17#mod-4498813045",
"memberOrganizationFamilyIds" : [ ],
"collectiveAgreementMerkuriusIds" : [
"a0ce80f7-ff07-de11-b4e1-02bf9e69ca65"
]
}
}';
my $regex = qr/"_id" : "CollectiveAgreement:(?!8|12|19|20|88|109)(\d).*?"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}