import re
regex = re.compile(r"\"_id\" : \"CollectiveAgreement:(?!8|12|19|20|88|109)(\d).*?\"", flags=re.MULTILINE)
test_str = ("{\n"
" \"_index\" : \"documents-prod\",\n"
" \"_type\" : \"_doc\",\n"
" \"_id\" : \"CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620\",\n"
" \"_score\" : 0.0,\n"
" \"_source\" : {\n"
" \"id\" : \"CollectiveAgreement:19-Document:17-DocumentSection:269757-DocumentModule:320620\",\n"
" \"type\" : \"CollectiveAgreement\",\n"
" \"title\" : \"Bemanning LO-förbunden (adm. ansvarigt förb. Musikerförbundet)\",\n"
" \"text\" : \"Ordinarie arbetstid uppgår för heltidsanställd till 40 tim per helgfri vecka i genomsnitt per 4-veckorsperiod. Efter lokal överenskommelse kan längre begränsningsperioder tillämpas.\",\n"
" \"path\" : \"/agreements/19/documents/17#mod-4498813045\",\n"
" \"memberOrganizationFamilyIds\" : [ ],\n"
" \"collectiveAgreementMerkuriusIds\" : [\n"
" \"a0ce80f7-ff07-de11-b4e1-02bf9e69ca65\"\n"
" ]\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")