const regex = /(?<PREFIX>somestring)\d*/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<PREFIX>somestring)\\d*', 'gu')
const str = `somestring1234`;
const subst = `${PREFIX}1000`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);