use strict;
my $str = 'somestring1234';
my $regex = qr/(?<PREFIX>somestring)\d*/up;
my $subst = '${PREFIX}1000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";