$re = '/(?<PREFIX>somestring)\d*/u';
$str = 'somestring1234';
$subst = "${PREFIX}1000";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;