import re
regex = re.compile(r"(?<PREFIX>somestring)\d*", flags=re.UNICODE)
test_str = "somestring1234"
subst = "${PREFIX}1000"
result = regex.sub(subst, test_str)
if result:
print(result)