package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)heading1\n(.*)\n{2}?`)
var str = `heading1
foo=bar
baz=qux
heading2
spam=ham
heading3
this=that`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}