re = / imageNamed:NSLocalizedString\((@"[^"]*[\u4E00-\u9FA5]+[^"\n]*?"), nil\)/m
str = '[UIImage imageNamed:NSLocalizedString(@"你好", nil)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end