// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m) imageNamed:NSLocalizedString\((@"[^"]*[\u4E00-\u9FA5]+[^"\n]*?"), nil\)"#).unwrap();
let string = "[UIImage imageNamed:NSLocalizedString(@\"你好\", nil)]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}