$re = '/\d+(?:,\d+){0,}/m';
$str = '1–16 of more than 8,000 results
1–1,1 of more, than 8,000 results 1,
,0123,123,123,654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);