# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\'n_objects=([0-9]+)\:.*//gm;t' <<< "{'BB912E94CDE0B0E': (None, 'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\n')}"