re = /.*[&?]personId=([0-9]+)/m
str = 'https://server.com/de/prints/?personId=56'
subst = 'https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result