import Foundation
let pattern = #"(distroEnrollment Question )(\d{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
distroEnrollment Question 2",
distroEnrollment Question 2
distroEnrollment Question 3
distroEnrollment Question 31
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)