$re = '/^http(s)?:\/\/www.example\.com/';
$str = 'http://www.example.com/sub/path/and/file.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);