re = /^http(s)?:\/\/www.example\.com/
str = 'http://www.example.com/sub/path/and/file.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end